$re = '/\'([^@\']*@\d[^@\']*)\'/m';
$str = '\'package@1.1.k\' \'otherpackage@14\' \'anotherpackage@7.8\'
export MYVAR="/dir/\'package@1.1.k\':$MYVAR"';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;