package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'([^@']*@\d[^@']*)'`)
var str = `'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'
export MYVAR="/dir/'package@1.1.k':$MYVAR"`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}