#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)'([^@']*@\d[^@']*)'"
Local $sString = "'package@1.1.k' 'otherpackage@14' 'anotherpackage@7.8'" & @CRLF & _
"export MYVAR="/dir/'package@1.1.k':$MYVAR""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)