use strict;
my $str = 'android:paddingLeft = 10dp';
my $regex = qr/(android:paddingLeft(\s*=\s*\w+))/mp;
my $subst = '\\1\\nandroid:paddingStart\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";