re = /(android:paddingLeft(\s*=\s*\w+))/m
str = 'android:paddingLeft = 10dp'
subst = '\\1\\nandroid:paddingStart\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result