import re
regex = re.compile(r"(android:paddingLeft(\s*=\s*\w+))", flags=re.MULTILINE)
test_str = "android:paddingLeft = 10dp"
subst = "\\1\\nandroid:paddingStart\\2"
result = regex.sub(subst, test_str)
if result:
print(result)