// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(android:paddingLeft(\s*=\s*\w+))").unwrap();
let string = "android:paddingLeft = 10dp";
let substitution = "\\1\\nandroid:paddingStart\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}