# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)/$2µ/gm;t' <<< "<micro"