const regex = /(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\\bmicro)', 'gm')
const str = `<micro`;
const subst = `$2µ`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);