import re
regex = re.compile(r"(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)", flags=re.MULTILINE)
test_str = "<micro"
subst = "$2µ"
result = regex.sub(subst, test_str)
if result:
print(result)