using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)";
string substitution = @"$2µ";
string input = @"<micro";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}