re = /(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)/m
str = '<micro'
subst = '$2µ'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result