use strict;
my $str = '<micro';
my $regex = qr/(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)/mp;
my $subst = '$2µ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";