package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[^>]*>|&[^;]*;)(*SKIP)(*FAIL)|(<)?(\bmicro)`)
var str = `<micro`
var substitution = "$2µ"
fmt.Println(re.ReplaceAllString(str, substitution))
}