import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\"\\S+\" ){2}";
final String string = "\"te123st\" \"50:abcdtfkjhg\" \"ixcvixi\"\n";
final String subst = "$0\"dobavil11\" //";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}