// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:"\S+" ){2}"#).unwrap();
let string = "\"te123st\" \"50:abcdtfkjhg\" \"ixcvixi\"
";
let substitution = "$0\"dobavil11\" //";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}