# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\s\d]*\d\S*/NUMBER/gm;t' <<< "I made $425
I got mine at 42c. per share
Stocks saw a 12% increase"