package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s\d]*\d\S*`)
var str = `I made $425
I got mine at 42c. per share
Stocks saw a 12% increase`
var substitution = "NUMBER"
fmt.Println(re.ReplaceAllString(str, substitution))
}