$re = '/[^\s\d]*\d\S*/m';
$str = 'I made $425
I got mine at 42c. per share
Stocks saw a 12% increase';
$subst = "NUMBER";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;