import re
regex = re.compile(r"[^\s\d]*\d\S*", flags=re.MULTILINE)
test_str = ("I made $425\n"
"I got mine at 42c. per share\n"
"Stocks saw a 12% increase")
subst = "NUMBER"
result = regex.sub(subst, test_str)
if result:
print(result)