import Foundation
let pattern = #"[^\s\d]*\d\S*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I made $425
I got mine at 42c. per share
Stocks saw a 12% increase
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"NUMBER"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)