// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\s\d]*\d\S*").unwrap();
let string = "I made $425
I got mine at 42c. per share
Stocks saw a 12% increase";
let substitution = "NUMBER";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}