re = /[^\s\d]*\d\S*/m
str = 'I made $425
I got mine at 42c. per share
Stocks saw a 12% increase'
subst = 'NUMBER'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result