use strict;
my $str = 'I made $425
I got mine at 42c. per share
Stocks saw a 12% increase';
my $regex = qr/[^\s\d]*\d\S*/mp;
my $subst = 'NUMBER';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";