#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\s\d]*\d\S*"
Local $sString = "I made $425" & @CRLF & _
"I got mine at 42c. per share" & @CRLF & _
"Stocks saw a 12% increase"
Local $sSubst = "NUMBER"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)