package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)`)
var str = `
return scheduler
end)
package.preload['packages.utils.toluaEx'] = (function (...)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}