const regex = new RegExp('package\\.preload\\[\\s*(?P<qute>[\\'\\"])(\\w+(?:\\.\\w+)*)(?P=qute)\\s*\\]\\s*=\\s*\\(\\s*function\\s*\\(\\s*\\.{3}\\s*\\)', '')
const str = `
return scheduler
end)
package.preload['packages.utils.toluaEx'] = (function (...)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}