// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)"#).unwrap();
let string = "
return scheduler
end)
package.preload['packages.utils.toluaEx'] = (function (...)
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}