re = /package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)/
str = '
return scheduler
end)
package.preload[\'packages.utils.toluaEx\'] = (function (...)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end