import Foundation
let pattern = #"package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
return scheduler
end)
package.preload['packages.utils.toluaEx'] = (function (...)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}