import re
regex = re.compile(r"package\.preload\[\s*(?P<qute>['\"])(\w+(?:\.\w+)*)(?P=qute)\s*\]\s*=\s*\(\s*function\s*\(\s*\.{3}\s*\)")
test_str = ("\n"
"return scheduler\n\n"
"end)\n\n\n"
"package.preload['packages.utils.toluaEx'] = (function (...)\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")