# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/?)(.+?)(>)/<span>$1<\/span><span>$2<\/span><span>$3<\/span>/g;t' <<< "<head></head>"