re = /(<\/?)(.+?)(>)/
str = '<head></head>'
subst = '<span>$1</span><span>$2</span><span>$3</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result