using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/?)(.+?)(>)";
string substitution = @"<span>$1</span><span>$2</span><span>$3</span>";
string input = @"<head></head>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}