use strict;
my $str = '<head></head>';
my $regex = qr/(<\/?)(.+?)(>)/p;
my $subst = '<span>$1</span><span>$2</span><span>$3</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";