package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/?)(.+?)(>)`)
var str = `<head></head>`
var substitution = "<span>$1</span><span>$2</span><span>$3</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}