const regex = /(<\/?)(.+?)(>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/?)(.+?)(>)', 'g')
const str = `<head></head>`;
const subst = `<span>$1</span><span>$2</span><span>$3</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);