import re
regex = re.compile(r"(<\/?)(.+?)(>)")
test_str = "<head></head>"
subst = "<span>$1</span><span>$2</span><span>$3</span>"
result = regex.sub(subst, test_str)
if result:
print(result)