use strict;
my $str = 'U S lknsf l kasf
U.S. olasndflkasdas
S F F S F ';
my $regex = qr/\b\w\b \b\w\b/p;
my $subst = 'US';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";