import Foundation
let pattern = #"\b\w\b \b\w\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
U S lknsf l kasf
U.S. olasndflkasdas
S F F S F
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"US"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}