# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\{(\d+)(,(\d+))?\}\}/<input name="var$1" value="$3" \/>/gmi;t' <<< "This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like."