import Foundation
let pattern = #"\{\{(\d+)(,(\d+))?\}\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<input name="var$1" value="$3" />"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)