package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\{\{(\d+)(,(\d+))?\}\}`)
var str = `This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.`
var substitution = "<input name="var$1" value="$3" />"
fmt.Println(re.ReplaceAllString(str, substitution))
}