import re
regex = re.compile(r"\{\{(\d+)(,(\d+))?\}\}", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("This is my first example string. {{1}} This is what it looks like.\n"
"This is my second example string. {{1,2}}. This is what it looks like.\n"
"This is my third example string. {{1,3}} and {{2}}. This is what it looks like.")
subst = "<input name=\"var$1\" value=\"$3\" />"
result = regex.sub(subst, test_str)
if result:
print(result)