$re = '/\{\{(\d+)(,(\d+))?\}\}/mi';
$str = 'This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.';
$subst = "<input name=\"var$1\" value=\"$3\" />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;