import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(\\d+)(,(\\d+))?\\}\\}";
final String string = "This is my first example string. {{1}} This is what it looks like.\n"
+ "This is my second example string. {{1,2}}. This is what it looks like.\n"
+ "This is my third example string. {{1,3}} and {{2}}. This is what it looks like.";
final String subst = "<input name=\"var$1\" value=\"$3\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}