const regex = /\{\{(\d+)(,(\d+))?\}\}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(\\d+)(,(\\d+))?\\}\\}', 'gmi')
const str = `This is my first example string. {{1}} This is what it looks like.
This is my second example string. {{1,2}}. This is what it looks like.
This is my third example string. {{1,3}} and {{2}}. This is what it looks like.`;
const subst = `<input name="var$1" value="$3" />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);