#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "runScript(?<match>\((?:\g<match>|[^()]++)*\))"
Local $sString = "runScript("test")" & @CRLF & _
"" & @CRLF & _
" runScript( "test2" )" & @CRLF & _
"" & @CRLF & _
"runScript(ros.find("p")+ "script/test3")" & @CRLF & _
"" & @CRLF & _
"if( true) then { runScript(ros.find("p")+ "script/test4")}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"if( runScript(ros.find("p")+ "script/test5") ) then{" & @CRLF & _
"" & @CRLF & _
" print.ln("happy")" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"runScript(" & @CRLF & _
"" & @CRLF & _
"ros.find("p")+ "script/test6"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")