use strict;
my $str = 'runScript("test")
runScript( "test2" )
runScript(ros.find("p")+ "script/test3")
if( true) then { runScript(ros.find("p")+ "script/test4")}
if( runScript(ros.find("p")+ "script/test5") ) then{
print.ln("happy")
}
runScript(
ros.find("p")+ "script/test6"
)
';
my $regex = qr/runScript(?<match>\((?:\g<match>|[^()]++)*\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}