import re
regex = re.compile(r"runScript(?<match>\((?:\g<match>|[^()]++)*\))")
test_str = ("runScript(\"test\")\n\n"
" runScript( \"test2\" )\n\n"
"runScript(ros.find(\"p\")+ \"script/test3\")\n\n"
"if( true) then { runScript(ros.find(\"p\")+ \"script/test4\")}\n\n\n"
"if( runScript(ros.find(\"p\")+ \"script/test5\") ) then{\n\n"
" print.ln(\"happy\")\n"
"}\n\n"
"runScript(\n\n"
"ros.find(\"p\")+ \"script/test6\"\n\n\n"
")\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")